Any modern browser should do the trick, specifically the following versions or later are supported:

  • Chrome, Firefox, Microsoft Edge automatically update so they will always be ready
  • Safari 8+
  • Safari 8+ for iPhone/iPad
  • Internet Explorer 10+
  • Chrome for Android
Did this answer your question?